Cisco Nexus 5010 - Secondary power supply.

Quick note on secondary power supplies in Cisco Nexus 5010.

Today I did some maintenance with Nexus 5010 - installed secondary power supplies and rerouted power cables. It was pretty straightforward. Here is the status without secondary power supply:

n5k-1# show environment power 

Power Supply:
Voltage: 12 Volts
-----------------------------------------------------------
PS  Model                Input Power       Power     Status
                         Type  (Watts)     (Amp)
-----------------------------------------------------------
1   N5K-PAC-550W         AC     544.56     45.38     ok
2   --                   --         --        --     absent              

Mod Model                   Power     Power       Power     Power       Status
                            Requested Requested   Allocated Allocated
                            (Watts)   (Amp)       (Watts)   (Amp)
--- ----------------------  -------   ----------  --------- ----------  ----------
1    N5K-C5010P-BF-SUP      349.20    29.10       349.20    29.10       powered-up

Power Usage Summary:
--------------------
Power Supply redundancy mode:                 Redundant
Power Supply redundancy operational mode:     Non-redundant

Total Power Capacity                              544.56 W

Power reserved for Supervisor(s)                  349.20 W
Power currently used by Modules                     0.00 W

                                                -------------
Total Power Available                             195.36 W
                                                -------------
n5k-1#

I followed Cisco Nexus 5000 Series Hardware Installation Guide > Replacing or Installing Power Supplies. After you install secondary power supply you will see the following syslog messages. If power cable is not plugged in yet you will see “FAIL” yellow led on PS.

2019 Apr 29 08:41:30 n5k1 %PFMA-5-PS_FOUND: Power supply 2 found (Serial number DTM142700X1)
2019 Apr 29 08:41:30 n5k1 %NOHMS-2-NOHMS_DIAG_ERR_PS_FAIL: System minor alarm on power supply 2: failed
2019 Apr 29 08:41:30 n5k1 %PFMA-2-PS_FAIL: Power supply 2 failed or shutdown (Serial number DTM142700X1)

Status with two PSUs installed, but cable is not yet connected to the 2nd PSU:

n5k1# show environment power 

Power Supply:
Voltage: 12 Volts
-----------------------------------------------------------
PS  Model                Input Power       Power     Status
                         Type  (Watts)     (Amp)
-----------------------------------------------------------
1   N5K-PAC-550W         AC     544.56     45.38     ok
2   --                   --         --        --     fail/shutdown       

Mod Model                   Power     Power       Power     Power       Status
                            Requested Requested   Allocated Allocated
                            (Watts)   (Amp)       (Watts)   (Amp)
--- ----------------------  -------   ----------  --------- ----------  ----------
1    N5K-C5010P-BF-SUP      349.20    29.10       349.20    29.10       powered-up

Power Usage Summary:
--------------------
Power Supply redundancy mode:                 Redundant
Power Supply redundancy operational mode:     Non-redundant

Total Power Capacity                              544.56 W

Power reserved for Supervisor(s)                  349.20 W
Power currently used by Modules                     0.00 W

                                                -------------
Total Power Available                             195.36 W
                                                -------------
n5k1#

After I plugged in the power cable I had to wait ~15 seconds to get the following syslog messages:

2019 Apr 29 08:45:42 n5k-1 %NOHMS-2-NOHMS_DIAG_ERR_PS_RECOVERED: Recovered: System minor alarm on power supply 2: failed

Here is the status with two PSUs and both cables plugged in:

n5k-1# show environment power 

Power Supply:
Voltage: 12 Volts
-----------------------------------------------------------
PS  Model                Input Power       Power     Status
                         Type  (Watts)     (Amp)
-----------------------------------------------------------
1   N5K-PAC-550W         AC     544.56     45.38     ok
2   N5K-PAC-550W         AC     544.56     45.38     ok                  

Mod Model                   Power     Power       Power     Power       Status
                            Requested Requested   Allocated Allocated
                            (Watts)   (Amp)       (Watts)   (Amp)
--- ----------------------  -------   ----------  --------- ----------  ----------
1    N5K-C5010P-BF-SUP      349.20    29.10       349.20    29.10       powered-up

Power Usage Summary:
--------------------
Power Supply redundancy mode:                 Redundant
Power Supply redundancy operational mode:     Redundant

Total Power Capacity                             1089.12 W

Power reserved for Supervisor(s)                  349.20 W
Power currently used by Modules                     0.00 W

                                                -------------
Total Power Available                             739.92 W
                                                -------------
n5k-1#

Then to reroute power cables I disconnected 1st power supply for ~5 seconds and haven’t got any syslog messages. So, there’s some delay and you have to be aware that brief power cable disconnection will not be registered in the logs.

Good luck!

Admin area