How to download Session Videos from ciscolive.cisco.com. [TESTED]

Every single decent network engineer knows that ciscolive.cisco.com has A LOT of technical knowledge, brilliant deep dive presentations that you might want to download WITH session videos. Just check On-Demand Library and 100% you will find something interesting for you. Well, the problem for me was to get offline copy of presentation video. I don’t know how to get the video easier, but was able to google the following way:

• Load the video in FireFix browser.
• Press “Ctrl+Shift+E” to open Network Monitor in Firefox on Windows.
• Refresh or reload the page.
• You should see tons of requests in the network monitor list. Sort the list by File column and try to find the one entry with all digits value under the File column, such as 5647924234001, and likely the domain associated should be (at least currently): edge.api.brightcove.com
• Right click on the entry and select “Copy Response”.
• Paste the response into notepad and search for “MP4”.
• Paste the link from response to a new browser tab.
• Once the page loaded, right click on the video and “Save Video As…”.

Good luck!

Cisco - Simple reachability test TCL script.

Here is basic Cisco Router/Switch TCL script to test IP reachability of multiple target IPs:

tclsh
foreach VAR {
8.8.8.8
8.8.4.4
1.1.1.1
} { ping $VAR }

Expected result:

Cisco(tcl)#foreach VAR {
+>8.8.8.8
+>8.8.4.4
+>1.1.1.1
+>} { ping $VAR }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/42 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/17 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/17 ms
Cisco(tcl)#exit
Cisco#

MikroTik ROS - Time sync OR NTP client configuration.

If MikroTik device has internet access the easiest way for me to configure time synchronization is to use publicly available NTP servers and use DNS names instead of IPs:

We will need to configure DNS client to be able to resolve hostnames into IPs:

/ip dns set servers=8.8.8.8,1.1.1.1 allow-remote-requests=no

Here is the way to check if DNS client works or not:

[admin@MikroTik] > :put [:resolve mikrotik.com]
159.148.147.196
[admin@MikroTik] >

Otherwise you will see an error:

[admin@MikroTik] > :put [:resolve mikrotik.com]
failure: dns server failure
[admin@MikroTik] >

If DNS is working fine we can go ahead and configure one or multiple DNS names for NTP server. In addition to that we would configure TimeZone:

/system clock set time-zone-name=PST8PDT
/system ntp client set enabled=yes server-dns-names=0.us.pool.ntp.org,1.us.pool.ntp.org,2.us.pool.ntp.org

Check if RouterOS was able to synchronize the time with any of NTP servers:

[admin@MikroTik] > /system ntp client print
           enabled: yes
       primary-ntp: 0.0.0.0
     secondary-ntp: 0.0.0.0
  server-dns-names: 0.us.pool.ntp.org,1.us.pool.ntp.org,2.us.pool.ntp.org
              mode: unicast
     poll-interval: 16s
     active-server: 184.105.182.15
[admin@MikroTik] >

As you can see there’s an IP in “active-server” field. That means it’s all good. Now we can check current time in RouterOS:

[admin@MikroTik] > /system clock print
                  time: 09:33:46
                  date: dec/14/2018
  time-zone-autodetect: yes
        time-zone-name: PST8PDT
            gmt-offset: -08:00
            dst-active: no
[admin@MikroTik] >

Good luck!

MikroTik ROS - How to reorder firewall rules.

As you might know, MikroTik RouterOS has a great CLI and built-in scripting language which is extremely versatile. There was a time when RouterOS had Lua language, but not anymore. I enjoy of using CLI for whatever I do and it’s the most efficient way to operate ROS.

One of the most biggest configuration sections in RouterOS is “/ip firewall filter” and might be huge and cumbersome. In addition to the syntax for firewall rules should should know how to put the rules in the right order. There’s re two major commands here:

move - changes the order of items in list.

Parameters:
• first argument specifies the item(-s) being moved.
• second argument specifies the item before which to place all items being moved (they are placed at the end of the list if the second argument is omitted).

/ip firewall filter move 1 0

Keep in mind that recommended way is to use “internal IDs” (you would use find command). Otherwise you will need to execute “/ip firewall filter print” a lot. More info can be found here - Modify firewall order or add firewall with script.

place-before parameter that use can use to specify the place where to put the rule.

Here is an example how to place the rule at the very beginning of the list:

/ip firewall filter add chain=input action=accept place-before=0

The same concept of using “internal IDs” is recommended.

Good luck!

MikroTik ROS - “show ip route” command.

If you are looking for “show ip route” CLI command in MikroTik ROS here is the answer:

[admin@MikroTik] > /ip route print where 8.8.8.8 in dst-address
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                          172.20.7.17             110
[admin@MikroTik] >

Keep in mind this result does NOT take into account Mangle Rules that you might have configured.

Check this forum thread if any questions.

Admin area